VCOM:VectorWorks:IFCLib:IIFCSupport::IFC DeleteEntry: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


Deletes the Ifc Entity and the Property Sets (PSets) mapped to it according to IFC Data Mapping
Deletes the Ifc Entity and the Property Sets (PSets) mapped to it according to IFC Data Mapping

Latest revision as of 15:20, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Deletes the Ifc Entity and the Property Sets (PSets) mapped to it according to IFC Data Mapping

VCOMError IFC_DeleteEntry(
const TXString& strObjectName,
const TXString& strEntryName);

Parameters

strObjectName TXString Object name from which the user is deleting.
strEntryName TXString Ifc Entity name which is going to be deleted.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017.