VCOM:VectorWorks:IFCLib:IIFCSupport::IFC CreateObjectGUID

From Vectorworks Developer
Revision as of 15:04, 19 June 2018 by NBeshevliev (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Creates GUID for the object. If the object has attached entity or IFC tag then nothing happens (the object already has GUID).

VCOMError IFC_CreateObjectGUID(
MCObjectHandle hOject,
bool bDoUndo = true);

Parameters

hObject MCObjectHandle Handle to the object.
bDoUndo bool Do use the undo system or not. True by default.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019