VCOM:VectorWorks:IFCLib:IIFCSupport::IFC CreateObjectGUID: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
(2 intermediate revisions by one other user not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Creates GUID for the object. If the object has attached entity or IFC tag then nothing happens (the object already has GUID).
</desc>
</desc>


Line 25: Line 25:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Handle to the object.
</line>
</line>
<line>
<line>
bDoUndo  
bDoUndo  
bool  
bool  
no info.
Do use the undo system or not. True by default.
</line>
</line>
</lineList>
</lineList>
Line 44: Line 44:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 71: Line 67:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2019
</version>
</version>


</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|IFC_CreateObjectGUID]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|IFC_CreateObjectGUID]]

Latest revision as of 15:04, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Creates GUID for the object. If the object has attached entity or IFC tag then nothing happens (the object already has GUID).

VCOMError IFC_CreateObjectGUID(
MCObjectHandle hOject,
bool bDoUndo = true);

Parameters

hObject MCObjectHandle Handle to the object.
bDoUndo bool Do use the undo system or not. True by default.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019