VCOM:VectorWorks:IFCLib:IIFCSupport::IFC CreateFormatEntity

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Creates IFC Format Record in the Document Header.

VCOMError IFC_CreateFormatEntity(
MCObjectHandle hDocument,
const TXString& strIfcObjName);

Parameters

hDocument MCObjectHandle Document's handle.
strIfcObjName TXString IFC Entity Name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.