VCOM:VectorWorks:IFCLib:IIFCSupport::IFC CreateFormatEntity: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(One intermediate revision by the same user not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Creates IFC Format Record in the Document Header.
</desc>
</desc>


Line 25: Line 25:
hDocument
hDocument
MCObjectHandle
MCObjectHandle
no info.
Document's handle.
</line>
</line>
<line>
<line>
strIfcObjName
strIfcObjName
TXString
TXString
no info.
IFC Entity Name.
</line>
</line>
</lineList>
</lineList>
Line 44: Line 44:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 71: Line 67:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from:  
Available from: Vectorworks 12.
</version>
</version>



Latest revision as of 13:45, 23 July 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Creates IFC Format Record in the Document Header.

VCOMError IFC_CreateFormatEntity(
MCObjectHandle hDocument,
const TXString& strIfcObjName);

Parameters

hDocument MCObjectHandle Document's handle.
strIfcObjName TXString IFC Entity Name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.