VCOM:VectorWorks:IFCLib:IIFCSupport::IFC CopyIFCData

From Vectorworks Developer
Revision as of 15:28, 19 June 2018 by NBeshevliev (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Copy IFC data from one object to another.

VCOMError IFC_CopyIFCData(
MCObjectHandle hSource,
MCObjectHandle hDestination,
short inMode);

Parameters

hSource MCObjectHandle Handle to object.
hDestination MCObjectHandle Handle to object.
inMode short Options for copying. Possible values are 0 (copy always, new UUID); 1 (copy always, keep the old UUID); 2(copy, if same type, new UUID) and 3(copy, if same type, keep the old UUID).

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError Routine succeeded.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2011.