VCOM:VectorWorks:IFCLib:IIFCSupport::IFC ClearPset

From Vectorworks Developer
Revision as of 09:57, 19 March 2018 by KGoranov (talk | contribs)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Delete the specified Property set from the object's record.

VCOMError IFC_ClearPset(
MCObjectHandle hObject,
const TXString& strIfcPsetName);

Parameters

hObject MCObjectHandle Handle to object.
strIfcPsetName TXString Name of the Property set

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

Please note that if this Property set is defined in the mapping, it is still going to be attached to the IFC entity.

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2016.

See Also

IFC ClearAllPsets

[[VCOM:VectorWorks:Extension:IIFCSupport::IFC ClearAllPsets|IFC ClearAllPsets]]