VCOM:VectorWorks:IFCLib:IIFCSupport::IFC ClearPset: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVCOM|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <...")
 
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
Delete the specified Property sets from the object.
</desc>
</desc>


Line 25: Line 25:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Handle to object.
</line>
</line>
<line>
<line>
strIfcPsetName
strIfcPsetName
TXString
TXString
no info.
Name of the Property set
</line>
</line>
</lineList>
</lineList>
Line 58: Line 58:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Please note that
Use this function via global pointer gIFC.  
Use this function via global pointer gIFC.  
</remark>  
</remark>  
Line 67: Line 69:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:Extension:IIFCSupport::IFC ClearAllPsets|IFC ClearAllPsets]]
</seeAlso>
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2016.
</version>
</version>



Revision as of 09:08, 19 March 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Delete the specified Property sets from the object.

VCOMError IFC_ClearPset(
MCObjectHandle hObject,
const TXString& strIfcPsetName);

Parameters

hObject MCObjectHandle Handle to object.
strIfcPsetName TXString Name of the Property set

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

Please note that

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2016.

See Also

IFC ClearAllPsets

[[VCOM:VectorWorks:Extension:IIFCSupport::IFC ClearAllPsets|IFC ClearAllPsets]]