VCOM:VectorWorks:IFCLib:IIFCSupport::IFC ClearPset: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(6 intermediate revisions by 2 users not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


Delete the specified Property set from the object's record.
Delete the specified Property set from the object's record.
Line 58: Line 58:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Please note that  
Please note that if this Property set is defined in the mapping, it is still going to be attached to the IFC entity. If that is the case the return value is going to be kVCOMError_Failed.
 


Use this function via global pointer gIFC.  
Use this function via global pointer gIFC.  
Line 69: Line 70:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:Extension:IIFCSupport::IFC ClearAllPsets|IFC ClearAllPsets]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC ClearAllPsets|IFC ClearAllPsets]]
</seeAlso>
</seeAlso>


Line 79: Line 80:
</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|IFC_ClearPset]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|IFC_ClearPset]]

Latest revision as of 15:13, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Delete the specified Property set from the object's record.

VCOMError IFC_ClearPset(
MCObjectHandle hObject,
const TXString& strIfcPsetName);

Parameters

hObject MCObjectHandle Handle to object.
strIfcPsetName TXString Name of the Property set

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

Please note that if this Property set is defined in the mapping, it is still going to be attached to the IFC entity. If that is the case the return value is going to be kVCOMError_Failed.


Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2016.

See Also

IFC ClearAllPsets

[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC ClearAllPsets|IFC ClearAllPsets]]