VCOM:VectorWorks:IFCLib:IIFCSupport::IFC ClearPset: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


Delete the specified Property set from the object's records.
Delete the specified Property set from the object's record.
</desc>
</desc>



Revision as of 09:08, 19 March 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Delete the specified Property set from the object's record.

VCOMError IFC_ClearPset(
MCObjectHandle hObject,
const TXString& strIfcPsetName);

Parameters

hObject MCObjectHandle Handle to object.
strIfcPsetName TXString Name of the Property set

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

Please note that

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2016.

See Also

IFC ClearAllPsets

[[VCOM:VectorWorks:Extension:IIFCSupport::IFC ClearAllPsets|IFC ClearAllPsets]]