VCOM:VectorWorks:IFCLib:IIFCSupport::IFC ClearIFCInfo: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Deletes all IFC records from the object.
</desc>
</desc>


Line 25: Line 25:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Handle to the object.
</line>
</line>
</lineList>
</lineList>
Line 36: Line 36:
Return value meaning:
Return value meaning:
<lineList ident=1>
<lineList ident=1>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the fuction.
</line>
<line>
<line>
kVCOMError_Failed
kVCOMError_Failed
Line 61: Line 57:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vecorworks 2009
</version>
</version>



Latest revision as of 08:08, 6 July 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Deletes all IFC records from the object.

VCOMError IFC_ClearIFCInfo(
MCObjectHandle hObject);

Parameters

hObject MCObjectHandle Handle to the object.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_Failed Routine failed.

Version

Available from: Vecorworks 2009