VCOM:VectorWorks:IFCLib:IIFCSupport::IFC ClearIFCInfo: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
(6 intermediate revisions by 3 users not shown)
Line 1: Line 1:
{{LocationMain|category=LocationVCOM|specific=}}
{{LocationMain|category=LocationVCOM|specific=}}
__TOC__
__TOC__
<vwDoc>
<vwDoc>
Line 8: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Deletes all IFC records from the object.
</desc>
</desc>


Line 16: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual VCOMErrorVCOM_CALLTYPE IFC_ClearIFCInfo(MCObjectHandle hObject) = 0;
VCOMError IFC_ClearIFCInfo(MCObjectHandle hObject);
</funcDef>
</funcDef>
</def>
</def>
Line 26: Line 25:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Handle to the object.
</line>
</line>
</lineList>
</lineList>
Line 37: Line 36:
Return value meaning:
Return value meaning:
<lineList ident=1>
<lineList ident=1>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the fuction.
</line>
<line>
<line>
kVCOMError_Failed
kVCOMError_Failed
Line 62: Line 57:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vecorworks 2009
</version>
</version>



Latest revision as of 08:08, 6 July 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Deletes all IFC records from the object.

VCOMError IFC_ClearIFCInfo(
MCObjectHandle hObject);

Parameters

hObject MCObjectHandle Handle to the object.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_Failed Routine failed.

Version

Available from: Vecorworks 2009