VCOM:VectorWorks:IFCLib:IIFCSupport::IFC ClearAllPsets: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(4 intermediate revisions by 2 users not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


Delete all Property sets for the object.
Delete all Property sets for the object.
Line 53: Line 53:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Please note that any functions defined in the mapping are still going to be attached.
Please note that any Property sets defined in the mapping are still going to be attached to the IFC entity.
 


Use this function via global pointer gIFC.  
Use this function via global pointer gIFC.  
Line 64: Line 65:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:Extension:IIFCSupport::IFC ClearPset|IFC ClearPset]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC ClearPset|IFC ClearPset]]
</seeAlso>
</seeAlso>


Line 74: Line 75:
</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|IFC_ClearAllPsets]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|IFC_ClearAllPsets]]

Latest revision as of 15:13, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Delete all Property sets for the object.

VCOMError IFC_ClearAllPsets(
MCObjectHandle hObject);

Parameters

hObject MCObjectHandle Handle to object.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

Please note that any Property sets defined in the mapping are still going to be attached to the IFC entity.


Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2016.

See Also

IFC ClearPset

[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC ClearPset|IFC ClearPset]]