VCOM:VectorWorks:IFCLib:IIFCSupport::IFC ClearAllPsets: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 53: Line 53:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Please note that any functions defined in the mapping are still going to be attached.
Use this function via global pointer gIFC.  
Use this function via global pointer gIFC.  
</remark>  
</remark>  

Revision as of 09:56, 19 March 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Delete all Property sets for the object.

VCOMError IFC_ClearAllPsets(
MCObjectHandle hObject);

Parameters

hObject MCObjectHandle Handle to object.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

Please note that any functions defined in the mapping are still going to be attached.

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2016.

See Also

IFC ClearPset

[[VCOM:VectorWorks:Extension:IIFCSupport::IFC ClearPset|IFC ClearPset]]