VCOM:VectorWorks:IFCLib:IIFCSupport::IFC AttachPset: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
(One intermediate revision by one other user not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


Attaches IFC Property Set to the object.
Attaches IFC Property Set to the object.
Line 72: Line 72:
</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|IFC_AttachPset]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|IFC_AttachPset]]

Latest revision as of 15:12, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Attaches IFC Property Set to the object.

VCOMError IFC_AttachPset(
MCObjectHandle hObject,
const TXString& strIfcPsetName);

Parameters

hObject MCObjectHandle Handle to object.
strIfcPsetName TXString Property Set name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError Routine succeeded.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Vectorworks 12