VCOM:VectorWorks:IFCLib:IIFCSupport::IFC AttachPset: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


Attaches IFC Property set to the object.
Attaches IFC Property Set to the object.
</desc>
</desc>


Line 30: Line 30:
strIfcPsetName
strIfcPsetName
TXString
TXString
Property set name.
Property Set name.
</line>
</line>
</lineList>
</lineList>

Revision as of 08:30, 9 March 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Attaches IFC Property Set to the object.

VCOMError IFC_AttachPset(
MCObjectHandle hObject,
const TXString& strIfcPsetName);

Parameters

hObject MCObjectHandle Handle to object.
strIfcPsetName TXString Property Set name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError Routine succeeded.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Vectorworks 12