VCOM:VectorWorks:IFCLib:IIFCSupport::IFC AddField: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Adds a new field to the specified entry or Pset.
</desc>
</desc>


Line 15: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
VCOMError IFC_AddField(const TXString& strObjectName, const TXString& strEntryName, const TXString& strFieldName, const short& type, bool bOptional, bool bEnable, bool bEmpty);
VCOMError IFC_AddField(const TXString& strObjectName, const TXString& strEntryName, const TXString& strFieldName, const short& type, bool bOptional, bool bEnable, bool bEmpty, const TXString& strPSetName = "");
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 25:
strObjectName
strObjectName
TXString
TXString
no info.
Object name.
</line>
</line>
<line>
<line>
strEntryName
strEntryName
TXString
TXString
no info.
Ifc entity name.
</line>
</line>
<line>
<line>
strFieldName
strFieldName
TXString
TXString
no info.
Field name.
</line>
</line>
<line>
<line>
type
type
short
short
no info.
Field type. Possible values are represented by [[VCOM:VectorWorks:IFCLib:IFCEnumerations|EIfcType]]
</line>
</line>
<line>
<line>
bOptional
bOptional
bool
bool
no info.
Boolean that determines whether the field is optional or mandatory.
</line>
</line>
<line>
<line>
bEnable
bEnable
bool
bool
no info.
Boolean that determines whether the field is enabled or disabled.
</line>
</line>
<line>
<line>
bEmpty
bEmpty
bool
bool
no info.
Boolean that determines whether the field is empty.
</line>
<line>
strPSetName
TXString
Property set name. The default value for this parameter is empty string. Only add this parameter if the field is to be added to this property set.
</line>
</line>
</lineList>
</lineList>
Line 69: Line 74:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 96: Line 97:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2019.
</version>
</version>



Latest revision as of 10:42, 18 September 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Adds a new field to the specified entry or Pset.

VCOMError IFC_AddField(
const TXString& strObjectName,
const TXString& strEntryName,
const TXString& strFieldName,
const short& type,
bool bOptional,
bool bEnable,
bool bEmpty,
const TXString& strPSetName = "");

Parameters

strObjectName TXString Object name.
strEntryName TXString Ifc entity name.
strFieldName TXString Field name.
type short Field type. Possible values are represented by EIfcType
bOptional bool Boolean that determines whether the field is optional or mandatory.
bEnable bool Boolean that determines whether the field is enabled or disabled.
bEmpty bool Boolean that determines whether the field is empty.
strPSetName TXString Property set name. The default value for this parameter is empty string. Only add this parameter if the field is to be added to this property set.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019.