VCOM:VectorWorks:IFCLib:IIFCSupport::IFC AddEntry: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 35: Line 35:
bEnable
bEnable
bool
bool
no info.
Boolean that determines whether the entry is enabled or disabled.
</line>
</line>
<line>
<line>
eEntityType
eEntityType
EIfcEntityType  
EIfcEntityType  
Ifc Entity Entry Type. Possible values are <b>ePrimary</b>, <b>eSecondary</b> and <b>eUnknown</b>
Entry Type. Possible values are <b>ePrimary</b>, <b>eSecondary</b> and <b>eUnknown</b>
</line>
</line>
</lineList>
</lineList>

Revision as of 14:45, 11 May 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Adds a new entry to the current mapping of the specified object.

VCOMError IFC_AddEntry(
const TXString& strObjectName,
const TXString& strEntryName,
bool bEnable,
EIfcEntityType eEntityType);

Parameters

strObjectName TXString Object Name.
strEntryName TXString Entry Name.
bEnable bool Boolean that determines whether the entry is enabled or disabled.
eEntityType EIfcEntityType Entry Type. Possible values are ePrimary, eSecondary and eUnknown

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019.