VCOM:VectorWorks:IFCLib:IIFCSupport::IFC AddEntry: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
Adds a new entry to the current mapping of the specified object.  
</desc>
</desc>


Line 15: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
VCOMError IFC_AddEntry(const TXString& strObjectName, const TXString& strEntryName, bool bEnable);
VCOMError IFC_AddEntry(const TXString& strObjectName, const TXString& strEntryName, bool bEnable, EIfcEntityType eEntityType);
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 25:
strObjectName
strObjectName
TXString
TXString
no info.
Object Name.
</line>
</line>
<line>
<line>
strEntryName
strEntryName
TXString
TXString
no info.
Entry Name.  
</line>
</line>
<line>
<line>
Line 36: Line 36:
bool
bool
no info.
no info.
</line>
<line>
eEntityType
EIfcEntityType
Ifc Entity Entry Type. Possible values are <b>ePrimary</b>, <b>eSecondary</b> and <b>eUnknown</b>
</line>
</line>
</lineList>
</lineList>
Line 49: Line 54:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 76: Line 77:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2019.
</version>
</version>



Revision as of 11:10, 11 May 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Adds a new entry to the current mapping of the specified object.

VCOMError IFC_AddEntry(
const TXString& strObjectName,
const TXString& strEntryName,
bool bEnable,
EIfcEntityType eEntityType);

Parameters

strObjectName TXString Object Name.
strEntryName TXString Entry Name.
bEnable bool no info.
eEntityType EIfcEntityType Ifc Entity Entry Type. Possible values are ePrimary, eSecondary and eUnknown

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019.