VCOM:VectorWorks:IFCLib:IIFCSupport::IFC AddEntry: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(5 intermediate revisions by 2 users not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Adds an entry to indicated object from current IFC Data Mapping.
</desc>
</desc>


Line 15: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
VCOMError IFC_AddEntry(const TXString& strObjectName, const TXString& strEntryName, bool bEnable);
VCOMError IFC_AddEntry(const TXString& strObjectName, const TXString& strEntryName, bool bEnable, EIfcEntityType eEntityType);
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 25:
strObjectName
strObjectName
TXString
TXString
no info.
Object Name.
</line>
</line>
<line>
<line>
strEntryName
strEntryName
TXString
TXString
no info.
Ifc Entity Name.  
</line>
</line>
<line>
<line>
bEnable
bEnable
bool
bool
no info.
Boolean that determines whether the entry is enabled or disabled.
</line>
<line>
eEntityType
EIfcEntityType
Entry Type. Possible values are <b>ePrimary</b>, <b>eSecondary</b> and <b>eUnknown</b>
</line>
</line>
</lineList>
</lineList>
Line 49: Line 54:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 76: Line 77:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2019.
</version>
</version>



Latest revision as of 07:36, 22 October 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Adds an entry to indicated object from current IFC Data Mapping.

VCOMError IFC_AddEntry(
const TXString& strObjectName,
const TXString& strEntryName,
bool bEnable,
EIfcEntityType eEntityType);

Parameters

strObjectName TXString Object Name.
strEntryName TXString Ifc Entity Name.
bEnable bool Boolean that determines whether the entry is enabled or disabled.
eEntityType EIfcEntityType Entry Type. Possible values are ePrimary, eSecondary and eUnknown

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019.