VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCProperty

From Vectorworks Developer
Revision as of 06:52, 11 April 2018 by NBeshevliev (talk | contribs)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Returns the property value of an entity property.

VCOMError GetIFCProperty(
MCObjectHandle hObject,
const TXString& instanceProperty,
TXString& outValue);

Parameters

hObject MCObjectHandle Handle to object.
instanceProperty TXString Is in the following format: "IFCEntity_name.property_name".
outValue TXString Returns the property value.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError Routine succeeded.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.

See Also

IIFCSupport::IFC_GetEntityProp

[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetEntityProp|IIFCSupport::IFC_GetEntityProp]]