VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCProperty: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


Returns the property value of an entity property.
Returns the an entity property value.
</desc>
</desc>



Revision as of 09:48, 24 April 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Returns the an entity property value.

VCOMError GetIFCProperty(
MCObjectHandle hObject,
const TXString& instanceProperty,
TXString& outValue);

Parameters

hObject MCObjectHandle Handle to object.
instanceProperty TXString Is in the following format: "IFCEntity_name.property_name".
outValue TXString Returns the property value.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError Routine succeeded.
kVCOMError_Failed Routine failed.

Remarks

Note that this function returns only property values from entities. For values from Property Sets please use IFC_GetPsetProp.

Note that this function will return a value only if there is an attached IFC record to the objects. If you want to have the IFC Data Mapping value for the property returned, please use IFC_GetEntityProp2.


Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.

See Also

IIFCSupport::IFC_GetEntityProp

[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetEntityProp|IIFCSupport::IFC_GetEntityProp]]