VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCProperty: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
Returns the property value of an entity property.
</desc>
</desc>


Line 15: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
VCOMError GetIFCProperty(MCObjectHandle hObject, const TXString& instanceProperty, TXString& outName);
VCOMError GetIFCProperty(MCObjectHandle hObject, const TXString& instanceProperty, TXString& outValue);
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 25:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Handle to object.
</line>
</line>
<line>
<line>
instanceProperty
instanceProperty
TXString
TXString
no info.
Is in the following format: "IFCEntity_name.property_name".
</line>
</line>
<line>
<line>
outName
outValue
TXString
TXString
no info.
Returns the property value.
</line>
</line>
</lineList>
</lineList>
Line 47: Line 47:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_NoError
Bad VCOM instance used to call the fuction.
Routine succeeded.
</line>
</line>
<line>
<line>
Line 68: Line 68:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetEntityProp|IIFCSupport::IFC_GetEntityProp]]
</seeAlso>
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 12.
</version>
</version>



Revision as of 06:52, 11 April 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Returns the property value of an entity property.

VCOMError GetIFCProperty(
MCObjectHandle hObject,
const TXString& instanceProperty,
TXString& outValue);

Parameters

hObject MCObjectHandle Handle to object.
instanceProperty TXString Is in the following format: "IFCEntity_name.property_name".
outValue TXString Returns the property value.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError Routine succeeded.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.

See Also

IIFCSupport::IFC_GetEntityProp

[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetEntityProp|IIFCSupport::IFC_GetEntityProp]]