VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCProperty: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(8 intermediate revisions by 2 users not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:Extension:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Returns the an entity property value.
</desc>
</desc>


Line 15: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
VCOMError GetIFCProperty(MCObjectHandle hObject, const TXString& instanceProperty, TXString& outName);
VCOMError GetIFCProperty(MCObjectHandle hObject, const TXString& instanceProperty, TXString& outValue);
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 25:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Handle to object.
</line>
</line>
<line>
<line>
instanceProperty
instanceProperty
const [[SDK:TXString]]&
TXString
no info.
Is in the following format: "IFCEntity_name.property_name".
</line>
</line>
<line>
<line>
outName
outValue
[[SDK:TXString]]&
TXString
no info.
Returns the property value.
</line>
</line>
</lineList>
</lineList>
Line 47: Line 47:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_NoError
Bad VCOM instance used to call the fuction.
Routine succeeded.
</line>
</line>
<line>
<line>
Line 59: Line 59:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Note that this function returns only property values from entities. For values from Property Sets please use [[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetPsetProp|IFC_GetPsetProp]].
Note that this function will return a value only if there is an attached IFC record to the objects. If you want to have the IFC Data Mapping value for the property returned, please use [[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetEntityProp2|IFC_GetEntityProp2]].
Use this function via global pointer gIFC.  
Use this function via global pointer gIFC.  
</remark>
</remark>
Line 68: Line 72:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetEntityProp|IIFCSupport::IFC_GetEntityProp]]
</seeAlso>
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 12.
</version>
</version>


</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|GetIFCProperty]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|GetIFCProperty]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|GetIFCProperty]]

Latest revision as of 15:02, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the an entity property value.

VCOMError GetIFCProperty(
MCObjectHandle hObject,
const TXString& instanceProperty,
TXString& outValue);

Parameters

hObject MCObjectHandle Handle to object.
instanceProperty TXString Is in the following format: "IFCEntity_name.property_name".
outValue TXString Returns the property value.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError Routine succeeded.
kVCOMError_Failed Routine failed.

Remarks

Note that this function returns only property values from entities. For values from Property Sets please use IFC_GetPsetProp.

Note that this function will return a value only if there is an attached IFC record to the objects. If you want to have the IFC Data Mapping value for the property returned, please use IFC_GetEntityProp2.


Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.

See Also

IIFCSupport::IFC_GetEntityProp

[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetEntityProp|IIFCSupport::IFC_GetEntityProp]]