VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCProperty: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 1: Line 1:
 
{{LocationMain|category=LocationVCOM|specific=}}
__TOC__
__TOC__
<vwDoc>
<vwDoc>
Line 15: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
VCOMErrorVCOM_GetIFCProperty(MCObjectHandle hObject, const TXString& instanceProperty, TXString& outName)
VCOMError GetIFCProperty(MCObjectHandle hObject, const TXString& instanceProperty, TXString& outName);
</funcDef>
</funcDef>
</def>
</def>
Line 59: Line 59:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Use this function via global pointer gIFC.
</remark>
</remark>



Revision as of 12:01, 23 January 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:Extension:IIFCSupport

...put some description here...

VCOMError GetIFCProperty(
MCObjectHandle hObject,
const TXString& instanceProperty,
TXString& outName);

Parameters

hObject MCObjectHandle no info.
instanceProperty const SDK:TXString& no info.
outName SDK:TXString& no info.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.