VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCProperty: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 15: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual VCOMErrorVCOM_CALLTYPE GetIFCProperty(MCObjectHandle hObject, const TXString& instanceProperty, TXString& outName) = 0;
VCOMErrorVCOM_GetIFCProperty(MCObjectHandle hObject, const TXString& instanceProperty, TXString& outName)
</funcDef>
</funcDef>
</def>
</def>

Revision as of 08:32, 14 January 2018

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:Extension:IIFCSupport

...put some description here...

VCOMErrorVCOM_GetIFCProperty(
MCObjectHandle hObject,
const TXString& instanceProperty,
TXString& outName)

Parameters

hObject MCObjectHandle no info.
instanceProperty const SDK:TXString& no info.
outName SDK:TXString& no info.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.