VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCObjectData: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
(Replaced content with "<font color="red">DO NOT USE THIS FUNCTION.</font> It is not supported.")
Line 1: Line 1:
{{LocationMain|category=LocationVCOM|specific=}}
<font color="red">DO NOT USE THIS FUNCTION.</font> It is not supported.
 
__TOC__
<vwDoc>
 
-----------------------------------------------------------------------------------------------------------
<desc>
namespace <code>VectorWorks::IFCLib</code>
 
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
 
...put some description here...
</desc>
 
-----------------------------------------------------------------------------------------------------------
<def>
<funcDef lang="cpp">
virtual VCOMErrorVCOM_CALLTYPE GetIFCObjectData(MCObjectHandle hObject, TXString& outIfcObjName, TXString& outIfcObjectUUID) = 0;
</funcDef>
</def>
 
-----------------------------------------------------------------------------------------------------------
<params>
<lineList ident=1>
<line>
hObject
MCObjectHandle
no info.
</line>
<line>
outIfcObjName
[[SDK:TXString]]&
no info.
</line>
<line>
outIfcObjectUUID
[[SDK:TXString]]&
no info.
</line>
</lineList>
</params>
 
-----------------------------------------------------------------------------------------------------------
<return>
Uses standard [[VCOM:VCOMError|VCOM Error Reporting]].
 
Return value meaning:
<lineList ident=1>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the fuction.
</line>
<line>
kVCOMError_Failed
Routine failed.
</line>
</lineList>
</return>
 
-----------------------------------------------------------------------------------------------------------
<remark>
</remark>
 
-----------------------------------------------------------------------------------------------------------
<sample>
</sample>
 
-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>
 
-----------------------------------------------------------------------------------------------------------
<version>
</version>
 
</vwDoc>
 
[[Category:VCOM:VectorWorks:Extension:IIFCSupport|GetIFCObjectData]]

Revision as of 12:26, 12 January 2018

DO NOT USE THIS FUNCTION. It is not supported.