VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCNameForSelection

From Vectorworks Developer
Revision as of 14:59, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Sets the outName parameter to the IFC name of the selection. If there is no IFC data in the selection the string will be "<None>". If the selection conatains objects with multiple IFC types the string will be empty. If the selection has no IFC data, but it's a default architectural type it will be indicated by "<Defauly-$IfcType>" string.

virtual VCOMErrorVCOM_CALLTYPE GetIFCNameForSelection(
TXString& outName) = 0;

Parameters

outName SDK:TXString& no info.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.