VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCNameForSelection

From Vectorworks Developer
Revision as of 10:15, 2 April 2018 by NBeshevliev (talk | contribs)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Sets the outName parameter to the IFC name of the selection. If there is no IFC data in the selection the string will be "<None>". If the selection conatains objects with multiple IFC types the string will be empty. If the selection has no IFC data, but it's a default architectural type it will be indicated by "<Defauly-$IfcType>" string.

VCOMError GetIFCNameForSelection(
TXString& outNameр MCObjectHandle hSelectedObject = NULL);

Parameters

outName TXString no info.
hSelectedObject MCObjectHandle Default value is NULL.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.