VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCNameForSelection: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(2 intermediate revisions by one other user not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


Sets the outName parameter to the IFC name of the selection.
Sets the outName parameter to the IFC name of the selection.
Line 75: Line 75:
</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|GetIFCNameForSelection]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|GetIFCNameForSelection]]

Latest revision as of 15:05, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Sets the outName parameter to the IFC name of the selection. If there is no IFC data in the selection the string will be "<None>". If the selection conatains objects with multiple IFC types the string will be empty. If the selection has no IFC data, but it's a default architectural type it will be indicated by "<Defauly-$IfcType>" string.

VCOMError GetIFCNameForSelection(
TXString& outNameр MCObjectHandle hSelectedObject = NULL);

Parameters

outName TXString no info.
hSelectedObject MCObjectHandle Default value is NULL.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.