VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCNameForSelection: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
No edit summary
 
(9 intermediate revisions by 3 users not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


Sets the outName parameter to the IFC name of the selection.
Sets the outName parameter to the IFC name of the selection.
Line 18: Line 18:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual VCOMErrorVCOM_CALLTYPE GetIFCNameForSelection(TXString& outName) = 0;
VCOMError GetIFCNameForSelection(TXString& outNameр MCObjectHandle hSelectedObject = NULL);
</funcDef>
</funcDef>
</def>
</def>
Line 27: Line 27:
<line>
<line>
outName
outName
[[SDK:TXString]]&
TXString
no info.
no info.
</line>
<line>
hSelectedObject
MCObjectHandle
Default value is NULL.
</line>
</line>
</lineList>
</lineList>
Line 52: Line 57:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Use this function via global pointer gIFC.
</remark>
</remark>


Line 64: Line 70:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 12.
</version>
</version>



Latest revision as of 15:05, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Sets the outName parameter to the IFC name of the selection. If there is no IFC data in the selection the string will be "<None>". If the selection conatains objects with multiple IFC types the string will be empty. If the selection has no IFC data, but it's a default architectural type it will be indicated by "<Defauly-$IfcType>" string.

VCOMError GetIFCNameForSelection(
TXString& outNameр MCObjectHandle hSelectedObject = NULL);

Parameters

outName TXString no info.
hSelectedObject MCObjectHandle Default value is NULL.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.