VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCNameForSelection: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
No edit summary
Line 18: Line 18:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual VCOMErrorVCOM_CALLTYPE GetIFCNameForSelection(TXString& outName) = 0;
virtual VCOMErrorVCOM_CALLTYPE GetIFCNameForSelection(TXString& outNameр MCObjectHandle hSelectedObject = NULL) = 0;
</funcDef>
</funcDef>
</def>
</def>
Line 29: Line 29:
[[SDK:TXString]]&
[[SDK:TXString]]&
no info.
no info.
</line>
<line>
hSelectedObject
MCObjectHandle
Default value is NULL.
</line>
</line>
</lineList>
</lineList>

Revision as of 12:36, 19 September 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Sets the outName parameter to the IFC name of the selection. If there is no IFC data in the selection the string will be "<None>". If the selection conatains objects with multiple IFC types the string will be empty. If the selection has no IFC data, but it's a default architectural type it will be indicated by "<Defauly-$IfcType>" string.

virtual VCOMErrorVCOM_CALLTYPE GetIFCNameForSelection(
TXString& outNameр MCObjectHandle hSelectedObject = NULL) = 0;

Parameters

outName SDK:TXString& no info.
hSelectedObject MCObjectHandle Default value is NULL.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.