VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCName2: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVCOM|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <...")
 
No edit summary
 
(3 intermediate revisions by 2 users not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Returns the attached IFC entity name. If there is not attached IFC entity, the function returned value is from IFC Data Mapping
</desc>
</desc>


Line 25: Line 25:
hSelectedObject
hSelectedObject
MCObjectHandle
MCObjectHandle
no info.
Handle to object.
</line>
</line>
<line>
<line>
outName
outName
TXString
TXString
no info.
Returns the IFC entity name.
</line>
</line>
</lineList>
</lineList>
Line 44: Line 44:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 67: Line 63:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCName|IIFCSupport::GetIFCName]]
</seeAlso>
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2018.
</version>
</version>


</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|GetIFCName2]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|GetIFCName2]]

Latest revision as of 15:04, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the attached IFC entity name. If there is not attached IFC entity, the function returned value is from IFC Data Mapping

VCOMError GetIFCName2(
MCObjectHandle hSelectedObject,
TXString& outName);

Parameters

hSelectedObject MCObjectHandle Handle to object.
outName TXString Returns the IFC entity name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018.

See Also

IIFCSupport::GetIFCName

[[VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCName|IIFCSupport::GetIFCName]]