VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCName2: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
Line 63: Line 63:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:Extension:IIFCSupport::GetIFCName|IIFCSupport::GetIFCName]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCName|IIFCSupport::GetIFCName]]
</seeAlso>
</seeAlso>


Line 73: Line 73:
</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|GetIFCName2]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|GetIFCName2]]

Revision as of 07:42, 5 April 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Returns the attached IFC entity name. If there is not attached IFC entity, the function returned value is from IFC Data Mapping

VCOMError GetIFCName2(
MCObjectHandle hSelectedObject,
TXString& outName);

Parameters

hSelectedObject MCObjectHandle Handle to object.
outName TXString Returns the IFC entity name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018.

See Also

IIFCSupport::GetIFCName

[[VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCName|IIFCSupport::GetIFCName]]