VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCName

From Vectorworks Developer
Revision as of 07:10, 2 April 2018 by NBeshevliev (talk | contribs)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:Extension:IIFCSupport

Returns the attached IFC entity name. If there is not attached IFC entity, the function returned value is from IFC Data Mapping and it will be indicated by "<Defauly-$IfcType>" string.

VCOMError GetIFCName(
MCObjectHandle hObject,
TXString& outName);

Parameters

hObject MCObjectHandle Handle to object.
outName TXString Returns the IFC entity name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError Routine succeeded.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.