VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCName: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
mNo edit summary
 
(2 intermediate revisions by 2 users not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:Extension:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


Returns the attached IFC entity name. If there is not attached IFC entity, the function returned value is from IFC Data Mapping and it will be indicated by "<Defauly-$IfcType>" string.   
Returns the attached IFC entity name. If there is not attached IFC entity, the function returned value is from IFC Data Mapping and it will be indicated by "<Default-$IfcType>" string.   
</desc>
</desc>


Line 63: Line 63:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:Extension:IIFCSupport::GetIFCName2|IIFCSupport::GetIFCName2]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCName2|IIFCSupport::GetIFCName2]]
</seeAlso>
</seeAlso>


Line 73: Line 73:
</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|GetIFCName]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|GetIFCName]]

Latest revision as of 13:15, 5 July 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the attached IFC entity name. If there is not attached IFC entity, the function returned value is from IFC Data Mapping and it will be indicated by "<Default-$IfcType>" string.

VCOMError GetIFCName(
MCObjectHandle hObject,
TXString& outName);

Parameters

hObject MCObjectHandle Handle to object.
outName TXString Returns the IFC entity name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError Routine succeeded.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.

See Also

IIFCSupport::GetIFCName2

[[VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCName2|IIFCSupport::GetIFCName2]]