VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCName: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
mNo edit summary
 
(10 intermediate revisions by 3 users not shown)
Line 1: Line 1:
 
{{LocationMain|category=LocationVCOM|specific=}}
__TOC__
__TOC__
<vwDoc>
<vwDoc>
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Returns the attached IFC entity name. If there is not attached IFC entity, the function returned value is from IFC Data Mapping and it will be indicated by "<Default-$IfcType>" string.
</desc>
</desc>


Line 15: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual VCOMErrorVCOM_CALLTYPE GetIFCName(MCObjectHandle hObject, TXString& outName) = 0;
VCOMError GetIFCName(MCObjectHandle hObject, TXString& outName);
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 25:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Handle to object.
</line>
</line>
<line>
<line>
outName
outName
[[SDK:TXString]]&
TXString
no info.
Returns the IFC entity name.
</line>
</line>
</lineList>
</lineList>
Line 42: Line 42:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_NoError
Bad VCOM instance used to call the fuction.
Routine succeeded.
</line>
</line>
<line>
<line>
Line 54: Line 54:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Use this function via global pointer gIFC.
</remark>
</remark>


Line 62: Line 63:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCName2|IIFCSupport::GetIFCName2]]
</seeAlso>
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 12.
</version>
</version>


</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|GetIFCName]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|GetIFCName]]

Latest revision as of 13:15, 5 July 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the attached IFC entity name. If there is not attached IFC entity, the function returned value is from IFC Data Mapping and it will be indicated by "<Default-$IfcType>" string.

VCOMError GetIFCName(
MCObjectHandle hObject,
TXString& outName);

Parameters

hObject MCObjectHandle Handle to object.
outName TXString Returns the IFC entity name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError Routine succeeded.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.

See Also

IIFCSupport::GetIFCName2

[[VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCName2|IIFCSupport::GetIFCName2]]