VCOM:VectorWorks:IFCLib:IIFCSupport::GetAllIFCNamesInDocument: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


Collects the IfcEntity names, attached and mapped from IFC Data Mapping, for all Objects in Document.
Collects the IfcEntity names, attached and mapped from IFC Data Mapping, for all Objects in Document.

Latest revision as of 15:01, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Collects the IfcEntity names, attached and mapped from IFC Data Mapping, for all Objects in Document.

VCOMError GetAllIFCNamesInDocument(
TXStringArray& outArrNames);

Parameters

outArrNames TXStringArray& Returned IfcEntity names.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError Routine succeeded.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.