VCOM:VectorWorks:IFCLib:IIFCSupport::GetAllIFCNamesInDocument: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
(2 intermediate revisions by 2 users not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:Extension:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Collects the IfcEntity names, attached and mapped from IFC Data Mapping, for all Objects in Document.
</desc>
</desc>


Line 25: Line 25:
outArrNames
outArrNames
TXStringArray&
TXStringArray&
no info.
Returned IfcEntity names.
</line>
</line>
</lineList>
</lineList>
Line 37: Line 37:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_NoError
Bad VCOM instance used to call the fuction.
Routine succeeded.
</line>
</line>
<line>
<line>
Line 62: Line 62:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 12.
</version>
</version>


</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|GetAllIFCNamesInDocument]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|GetAllIFCNamesInDocument]]

Latest revision as of 15:01, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Collects the IfcEntity names, attached and mapped from IFC Data Mapping, for all Objects in Document.

VCOMError GetAllIFCNamesInDocument(
TXStringArray& outArrNames);

Parameters

outArrNames TXStringArray& Returned IfcEntity names.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError Routine succeeded.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.