VCOM:VectorWorks:IFCLib:IIFCSupport

From Vectorworks Developer
Revision as of 08:09, 5 April 2018 by Sasha (talk | contribs)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VCOM:VectorWorks:IFCLib

Provides access to IFC features of Vectorworks. Available from Vectorworks 2019: Use all the functions via global pointer gIFC.

Members

I/O

ExportFile ImportFile

Dialogs

ShowExportOptions ShowIFCDataForSelection ShowManagePsetsDlg ShowObjectIFCDataEditDlg
ShowPickIFCTypeDlg ShowPickIFCTypeDlg2

Project Options

IFC_GetIFCScheme IFC_SetIFCScheme SetIFCScheme

Entities

GetAllIFCNamesInDocument GetIFCName GetIFCName2 GetIFCNameForSelection
IFC_CreateFormatEntity IFC_GetEntityColor IFC_GetEntityProp IFC_GetEntityProp2
IFC_GetIFCEntity IFC_GetIFCEntity2 IFC_SetEntityColor IFC_SetEntityProp
IFC_SetIFCEntity IFC_SetIFCEntity2

Property Sets (PSets)

IFC_AttachPset IFC_ClearAllPsets IFC_ClearPset IFC_DefPsetAddMember
IFC_DefPsetBegin IFC_DefPsetEnd IFC_GetNumPsets IFC_GetNumPsets2
IFC_GetPsetInfoAt IFC_GetPsetName IFC_GetPsetProp IFC_GetPsetProp2
IFC_GetPsetsForIFCType IFC_IsPsetCustom IFC_IsPsetDefined IFC_SetPsetProp

COBie

IFC_GetCOBieProperty IFC_GetCOBieSource WS_FillCOBieFixedWorksheets

Data Mapping

IFC_EnableObject IFC_GetEntriesCount IFC_GetFieldMapping IFC_GetFieldsCount
IFC_LoadMapSettings IFC_ReplaceDataWithMapping IFC_ResetMapToCOBieDefaults IFC_ResetMapToDefaults
IFC_SaveMapSettings IFC_SetFieldMapping

Vectorworks Records

IFC_GetParamIndex IFC_GetParamName IFC_GetParamStyle IFC_GetParamValue
IFC_GetParamsCount IFC_GetRecordLocalizedName IFC_IsIFCRecord

IFCLib

Others (without description)

GetIFCProperty IFC_AddEntry IFC_AddField IFC_ClearIFCInfo
IFC_CopyIFCData IFC_CreateObjectGUID IFC_DeleteEntry IFC_DeleteField
IFC_DeleteIFCInfo IFC_EnableEntry IFC_GetEntryName IFC_GetFieldName
IFC_GetFieldType IFC_GetFullEntitiesList IFC_GetIFCActiveDoc IFC_GetPropChoices
IFC_GetPropertiesList IFC_GetPropertiesListOfPset IFC_GetSpaceParamForObject IFC_GetSpaceParamForObject2
IFC_IsEntryEnabled IFC_IsFieldEmpty IFC_IsFieldEnabled IFC_IsFieldOptional
IFC_IsObjectEnabled IFC_SetFieldEmpty IFC_SetFieldEnabled IFC_SetFieldOptional
IFC_SetFieldType IFC_SetIFCProperty IFC_SetProperty

Obsolete Members (not supported)

CloseForDocument GetIFCObjectData UpdateVWDocumentIFCData

Remarks

There is predefined type for smart VCOM pointer VCOMPtr to IIFCSupport interface:

typedef VCOMPtr<IIFCSupport>  IIFCSupportPtr;

Version

Available from: Vectorworks 2013

See Also

IFC Enumerations

VCOM:VCOMPtr

[[VCOM:VectorWorks:IFCLib:IFCEnumerations|IFC Enumerations]] [[VCOM:VCOMPtr]]