VCOM:VectorWorks:IFCLib:IIFCSupport: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 62: Line 62:
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_DeleteIFCInfo|IFC_DeleteIFCInfo]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_DeleteIFCInfo|IFC_DeleteIFCInfo]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetPropChoices|IFC_GetPropChoices]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetPropChoices|IFC_GetPropChoices]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_ClearIFCInfo|IFC_ClearIFCInfo]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_CopyIFCData|IFC_CopyIFCData]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetFullEntitiesList|IFC_GetFullEntitiesList]]
</listTable>
</listTable>


Line 82: Line 85:
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetPsetInfoAt|IFC_GetPsetInfoAt]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetPsetInfoAt|IFC_GetPsetInfoAt]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_IsPsetCustom|IFC_IsPsetCustom]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_IsPsetCustom|IFC_IsPsetCustom]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetPropertiesListOfPset|IFC_GetPropertiesListOfPset]]
</listTable>
</listTable>


Line 115: Line 119:
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SetFieldType|IFC_SetFieldType]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SetFieldType|IFC_SetFieldType]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_DeleteField|IFC_DeleteField]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_DeleteField|IFC_DeleteField]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_IsObjectEnabled|IFC_IsObjectEnabled]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_IsEntryEnabled|IFC_IsEntryEnabled]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetFieldName|IFC_GetFieldName]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_AddField|IFC_AddField]]
</listTable>
</listTable>


Line 132: Line 140:
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetSpaceParamForObject|IFC_GetSpaceParamForObject]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetSpaceParamForObject|IFC_GetSpaceParamForObject]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetSpaceParamForObject2|IFC_GetSpaceParamForObject2]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetSpaceParamForObject2|IFC_GetSpaceParamForObject2]]
</listTable>
=== Others (without description) ===
<listTable indent="1">
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_ClearIFCInfo|IFC_ClearIFCInfo]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_CopyIFCData|IFC_CopyIFCData]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetFullEntitiesList|IFC_GetFullEntitiesList]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_IsObjectEnabled|IFC_IsObjectEnabled]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_IsEntryEnabled|IFC_IsEntryEnabled]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetFieldName|IFC_GetFieldName]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_AddField|IFC_AddField]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetPropertiesListOfPset|IFC_GetPropertiesListOfPset]]
</listTable>
</listTable>



Revision as of 07:02, 2 July 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VCOM:VectorWorks:IFCLib

Provides access to IFC features of Vectorworks. Use all the functions via global pointer gIFC.

Members

I/O

ExportFile ImportFile

Dialogs

ShowExportOptions ShowIFCDataForSelection ShowManagePsetsDlg ShowObjectIFCDataEditDlg
ShowPickIFCTypeDlg ShowPickIFCTypeDlg2

Project Options

IFC_GetIFCScheme IFC_SetIFCScheme SetIFCScheme

Entities

GetAllIFCNamesInDocument GetIFCName GetIFCName2 GetIFCNameForSelection
GetIFCProperty IFC_ClearIFCInfo IFC_CopyIFCData IFC_CreateFormatEntity
IFC_CreateObjectGUID IFC_DeleteIFCInfo IFC_GetEntityColor IFC_GetEntityProp
IFC_GetEntityProp2 IFC_GetFullEntitiesList IFC_GetIFCEntity IFC_GetIFCEntity2
IFC_GetPropChoices IFC_GetPropertiesList IFC_SetEntityColor IFC_SetEntityProp
IFC_SetIFCEntity IFC_SetIFCEntity2 IFC_SetIFCProperty IFC_SetProperty

Property Sets (PSets)

IFC_AttachPset IFC_ClearAllPsets IFC_ClearPset IFC_DefPsetAddMember
IFC_DefPsetBegin IFC_DefPsetEnd IFC_GetNumPsets IFC_GetNumPsets2
IFC_GetPropertiesListOfPset IFC_GetPsetInfoAt IFC_GetPsetName IFC_GetPsetProp
IFC_GetPsetProp2 IFC_GetPsetsForIFCType IFC_IsPsetCustom IFC_IsPsetDefined
IFC_SetPsetProp

COBie

IFC_GetCOBieProperty IFC_GetCOBieSource WS_FillCOBieFixedWorksheets

Data Mapping

IFC_AddEntry IFC_AddField IFC_DeleteEntry IFC_DeleteField
IFC_EnableEntry IFC_EnableObject IFC_GetEntriesCount IFC_GetEntryName
IFC_GetFieldMapping IFC_GetFieldName IFC_GetFieldType IFC_GetFieldsCount
IFC_IsEntryEnabled IFC_IsFieldEmpty IFC_IsFieldEnabled IFC_IsFieldOptional
IFC_IsObjectEnabled IFC_LoadMapSettings IFC_ReplaceDataWithMapping IFC_ResetMapToCOBieDefaults
IFC_ResetMapToDefaults IFC_SaveMapSettings IFC_SetFieldEmpty IFC_SetFieldEnabled
IFC_SetFieldMapping IFC_SetFieldType

Vectorworks Records

IFC_GetParamIndex IFC_GetParamName IFC_GetParamStyle IFC_GetParamValue
IFC_GetParamsCount IFC_GetRecordLocalizedName IFC_IsIFCRecord

Objects Support

IFC_GetSpaceParamForObject IFC_GetSpaceParamForObject2

Obsolete Members (not supported)

CloseForDocument GetIFCObjectData UpdateVWDocumentIFCData

Remarks

There is predefined type for smart VCOM pointer VCOMPtr to IIFCSupport interface:

typedef VCOMPtr<IIFCSupport>  IIFCSupportPtr;

Version

Available from: Vectorworks 2013

See Also

IFC Enumerations

VCOM:VCOMPtr

[[VCOM:VectorWorks:IFCLib:IFCEnumerations|IFC Enumerations]] [[VCOM:VCOMPtr]]