VCOM:VectorWorks:IFCLib:IIFCSupport: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 102: Line 102:
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetEntryName|IFC_GetEntryName]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetEntryName|IFC_GetEntryName]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_IsFieldEnabled|IFC_IsFieldEnabled]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_IsFieldEnabled|IFC_IsFieldEnabled]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SetFieldEnabled|IFC_SetFieldEnabled]]
</listTable>
</listTable>


Line 132: Line 133:
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_IsFieldEmpty|IFC_IsFieldEmpty]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_IsFieldEmpty|IFC_IsFieldEmpty]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SetFieldEmpty|IFC_SetFieldEmpty]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SetFieldEmpty|IFC_SetFieldEmpty]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SetFieldEnabled|IFC_SetFieldEnabled]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetFieldType|IFC_GetFieldType]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetFieldType|IFC_GetFieldType]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SetFieldType|IFC_SetFieldType]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SetFieldType|IFC_SetFieldType]]

Revision as of 13:28, 18 May 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VCOM:VectorWorks:IFCLib

Provides access to IFC features of Vectorworks. Use all the functions via global pointer gIFC.

Members

I/O

ExportFile ImportFile

Dialogs

ShowExportOptions ShowIFCDataForSelection ShowManagePsetsDlg ShowObjectIFCDataEditDlg
ShowPickIFCTypeDlg ShowPickIFCTypeDlg2

Project Options

IFC_GetIFCScheme IFC_SetIFCScheme SetIFCScheme

Entities

GetAllIFCNamesInDocument GetIFCName GetIFCName2 GetIFCNameForSelection
GetIFCProperty IFC_CreateFormatEntity IFC_CreateObjectGUID IFC_GetEntityColor
IFC_GetEntityProp IFC_GetEntityProp2 IFC_GetIFCEntity IFC_GetIFCEntity2
IFC_SetEntityColor IFC_SetEntityProp IFC_SetIFCEntity IFC_SetIFCEntity2

Property Sets (PSets)

IFC_AttachPset IFC_ClearAllPsets IFC_ClearPset IFC_DefPsetAddMember
IFC_DefPsetBegin IFC_DefPsetEnd IFC_GetNumPsets IFC_GetNumPsets2
IFC_GetPsetInfoAt IFC_GetPsetName IFC_GetPsetProp IFC_GetPsetProp2
IFC_GetPsetsForIFCType IFC_IsPsetCustom IFC_IsPsetDefined IFC_SetPsetProp

COBie

IFC_GetCOBieProperty IFC_GetCOBieSource WS_FillCOBieFixedWorksheets

Data Mapping

IFC_AddEntry IFC_DeleteEntry IFC_EnableObject IFC_GetEntriesCount
IFC_GetEntryName IFC_GetFieldMapping IFC_GetFieldsCount IFC_IsFieldEnabled
IFC_LoadMapSettings IFC_ReplaceDataWithMapping IFC_ResetMapToCOBieDefaults IFC_ResetMapToDefaults
IFC_SaveMapSettings IFC_SetFieldEnabled IFC_SetFieldMapping

Vectorworks Records

IFC_GetParamIndex IFC_GetParamName IFC_GetParamStyle IFC_GetParamValue
IFC_GetParamsCount IFC_GetRecordLocalizedName IFC_IsIFCRecord

Others (without description)

IFC_AddField IFC_ClearIFCInfo IFC_CopyIFCData IFC_DeleteField
IFC_DeleteIFCInfo IFC_EnableEntry IFC_GetFieldName IFC_GetFieldType
IFC_GetFullEntitiesList IFC_GetIFCActiveDoc IFC_GetPropChoices IFC_GetPropertiesList
IFC_GetPropertiesListOfPset IFC_GetSpaceParamForObject IFC_GetSpaceParamForObject2 IFC_IsEntryEnabled
IFC_IsFieldEmpty IFC_IsFieldOptional IFC_IsObjectEnabled IFC_SetFieldEmpty
IFC_SetFieldOptional IFC_SetFieldType IFC_SetIFCProperty IFC_SetProperty

Obsolete Members (not supported)

CloseForDocument GetIFCObjectData UpdateVWDocumentIFCData

Remarks

There is predefined type for smart VCOM pointer VCOMPtr to IIFCSupport interface:

typedef VCOMPtr<IIFCSupport>  IIFCSupportPtr;

Version

Available from: Vectorworks 2013

See Also

IFC Enumerations

VCOM:VCOMPtr

[[VCOM:VectorWorks:IFCLib:IFCEnumerations|IFC Enumerations]] [[VCOM:VCOMPtr]]