VCOM:VectorWorks:IFCLib:IIFCSupport: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
 
No edit summary
 
(30 intermediate revisions by 3 users not shown)
Line 1: Line 1:
#REDIRECT [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
{{LocationMain|category=LocationVCOM|specific=}}
__TOC__
<vwDoc>
 
-----------------------------------------------------------------------------------------------------------
<desc>
namespace <code>VCOM:VectorWorks:IFCLib</code>
 
Provides access to IFC features of Vectorworks. <font color="green">Use all the functions via global pointer '''gIFC'''</font>.
</desc>
 
-----------------------------------------------------------------------------------------------------------
<members>
<div class="rightmenu">
__TOC__
</div>
 
=== I/O ===
<listTable indent="1">
[[VCOM:VectorWorks:IFCLib:IIFCSupport::ImportFile|ImportFile]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::ExportFile|ExportFile]]
</listTable>
 
=== Dialogs ===
<listTable indent="1">
[[VCOM:VectorWorks:IFCLib:IIFCSupport::ShowObjectIFCDataEditDlg|ShowObjectIFCDataEditDlg]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::ShowPickIFCTypeDlg|ShowPickIFCTypeDlg]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::ShowExportOptions|ShowExportOptions]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::ShowIFCDataForSelection|ShowIFCDataForSelection]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::ShowManagePsetsDlg|ShowManagePsetsDlg]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::ShowPickIFCTypeDlg2|ShowPickIFCTypeDlg2]]
</listTable>
 
=== Project Options ===
<listTable indent="1">
[[VCOM:VectorWorks:IFCLib:IIFCSupport::SetIFCScheme|SetIFCScheme]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SetIFCScheme|IFC_SetIFCScheme]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetIFCScheme|IFC_GetIFCScheme]]
</listTable>
 
=== Entities ===
<listTable indent="1">
[[VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCProperty|GetIFCProperty]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SetIFCEntity|IFC_SetIFCEntity]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SetIFCEntity2|IFC_SetIFCEntity2]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetIFCEntity|IFC_GetIFCEntity]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetIFCEntity2|IFC_GetIFCEntity2]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SetEntityProp|IFC_SetEntityProp]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetEntityProp|IFC_GetEntityProp]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetEntityProp2|IFC_GetEntityProp2]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SetEntityColor|IFC_SetEntityColor]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetEntityColor|IFC_GetEntityColor]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_CreateFormatEntity|IFC_CreateFormatEntity]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCNameForSelection|GetIFCNameForSelection]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCName|GetIFCName]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::GetAllIFCNamesInDocument|GetAllIFCNamesInDocument]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCName2|GetIFCName2]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_CreateObjectGUID|IFC_CreateObjectGUID]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SetProperty|IFC_SetProperty]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SetIFCProperty|IFC_SetIFCProperty]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetPropertiesList|IFC_GetPropertiesList]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_DeleteIFCInfo|IFC_DeleteIFCInfo]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetPropChoices|IFC_GetPropChoices]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_ClearIFCInfo|IFC_ClearIFCInfo]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_CopyIFCData|IFC_CopyIFCData]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetFullEntitiesList|IFC_GetFullEntitiesList]]
</listTable>
 
=== Property Sets (PSets) ===
<listTable indent="1">
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetNumPsets|IFC_GetNumPsets]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetNumPsets2|IFC_GetNumPsets2]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetPsetName|IFC_GetPsetName]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_AttachPset|IFC_AttachPset]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SetPsetProp|IFC_SetPsetProp]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetPsetProp2|IFC_GetPsetProp2]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_ClearPset|IFC_ClearPset]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_ClearAllPsets|IFC_ClearAllPsets]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_DefPsetBegin|IFC_DefPsetBegin]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_DefPsetAddMember|IFC_DefPsetAddMember]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_DefPsetEnd|IFC_DefPsetEnd]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_IsPsetDefined|IFC_IsPsetDefined]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetPsetsForIFCType|IFC_GetPsetsForIFCType]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetPsetInfoAt|IFC_GetPsetInfoAt]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_IsPsetCustom|IFC_IsPsetCustom]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetPropertiesListOfPset|IFC_GetPropertiesListOfPset]]
</listTable>
 
=== COBie ===
<listTable indent="1">
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetCOBieProperty|IFC_GetCOBieProperty]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetCOBieSource|IFC_GetCOBieSource]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::WS_FillCOBieFixedWorksheets|WS_FillCOBieFixedWorksheets]]
</listTable>
 
=== Data Mapping ===
<listTable indent="1">
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetFieldMapping|IFC_GetFieldMapping]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SetFieldMapping|IFC_SetFieldMapping]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_LoadMapSettings|IFC_LoadMapSettings]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SaveMapSettings|IFC_SaveMapSettings]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_ReplaceDataWithMapping|IFC_ReplaceDataWithMapping]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_ResetMapToCOBieDefaults|IFC_ResetMapToCOBieDefaults]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_ResetMapToDefaults|IFC_ResetMapToDefaults]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetFieldsCount|IFC_GetFieldsCount]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_EnableObject|IFC_EnableObject]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetEntriesCount|IFC_GetEntriesCount]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_AddEntry|IFC_AddEntry]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_DeleteEntry|IFC_DeleteEntry]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetEntryName|IFC_GetEntryName]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_IsFieldEnabled|IFC_IsFieldEnabled]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SetFieldEnabled|IFC_SetFieldEnabled]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_EnableEntry|IFC_EnableEntry]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetFieldType|IFC_GetFieldType]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_IsFieldOptional|IFC_IsFieldOptional]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_IsFieldEmpty|IFC_IsFieldEmpty]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SetFieldEmpty|IFC_SetFieldEmpty]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SetFieldType|IFC_SetFieldType]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_DeleteField|IFC_DeleteField]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_IsObjectEnabled|IFC_IsObjectEnabled]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_IsEntryEnabled|IFC_IsEntryEnabled]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetFieldName|IFC_GetFieldName]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_AddField|IFC_AddField]]
</listTable>
 
=== Vectorworks Records  ===
<listTable indent="1">
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_IsIFCRecord|IFC_IsIFCRecord]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetRecordLocalizedName|IFC_GetRecordLocalizedName]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetParamName|IFC_GetParamName]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetParamIndex|IFC_GetParamIndex]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetParamStyle|IFC_GetParamStyle]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetParamValue|IFC_GetParamValue]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetParamsCount|IFC_GetParamsCount]]
</listTable>
 
=== Objects Support ===
<listTable indent="1">
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetSpaceParamForObject|IFC_GetSpaceParamForObject]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetSpaceParamForObject2|IFC_GetSpaceParamForObject2]]
</listTable>
 
=== Obsolete Members (not supported) ===
<listTable indent="1">
[[VCOM:VectorWorks:IFCLib:IIFCSupport::GetIFCObjectData|GetIFCObjectData]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::UpdateVWDocumentIFCData|UpdateVWDocumentIFCData]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::CloseForDocument|CloseForDocument]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetPsetProp|IFC_GetPsetProp]]
</listTable>
 
</members>
-----------------------------------------------------------------------------------------------------------
 
<remark>
There is predefined type for [[VCOM:VCOMPtr|smart VCOM pointer VCOMPtr]] to IIFCSupport interface:
 
<code lang="cpp">
typedef VCOMPtr<IIFCSupport>  IIFCSupportPtr;
</code>
</remark>
 
-----------------------------------------------------------------------------------------------------------
<sample>
</sample>
 
-----------------------------------------------------------------------------------------------------------
<version>
Available from: Vectorworks 2013
</version>
 
-----------------------------------------------------------------------------------------------------------
<seeAlso>
[[VCOM:VectorWorks:IFCLib:IFCEnumerations|IFC Enumerations]]
[[VCOM:VCOMPtr]]
</seeAlso>
 
</vwDoc>
 
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]

Latest revision as of 12:05, 27 August 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VCOM:VectorWorks:IFCLib

Provides access to IFC features of Vectorworks. Use all the functions via global pointer gIFC.

Members

I/O

ExportFile ImportFile

Dialogs

ShowExportOptions ShowIFCDataForSelection ShowManagePsetsDlg ShowObjectIFCDataEditDlg
ShowPickIFCTypeDlg ShowPickIFCTypeDlg2

Project Options

IFC_GetIFCScheme IFC_SetIFCScheme SetIFCScheme

Entities

GetAllIFCNamesInDocument GetIFCName GetIFCName2 GetIFCNameForSelection
GetIFCProperty IFC_ClearIFCInfo IFC_CopyIFCData IFC_CreateFormatEntity
IFC_CreateObjectGUID IFC_DeleteIFCInfo IFC_GetEntityColor IFC_GetEntityProp
IFC_GetEntityProp2 IFC_GetFullEntitiesList IFC_GetIFCEntity IFC_GetIFCEntity2
IFC_GetPropChoices IFC_GetPropertiesList IFC_SetEntityColor IFC_SetEntityProp
IFC_SetIFCEntity IFC_SetIFCEntity2 IFC_SetIFCProperty IFC_SetProperty

Property Sets (PSets)

IFC_AttachPset IFC_ClearAllPsets IFC_ClearPset IFC_DefPsetAddMember
IFC_DefPsetBegin IFC_DefPsetEnd IFC_GetNumPsets IFC_GetNumPsets2
IFC_GetPropertiesListOfPset IFC_GetPsetInfoAt IFC_GetPsetName IFC_GetPsetProp2
IFC_GetPsetsForIFCType IFC_IsPsetCustom IFC_IsPsetDefined IFC_SetPsetProp

COBie

IFC_GetCOBieProperty IFC_GetCOBieSource WS_FillCOBieFixedWorksheets

Data Mapping

IFC_AddEntry IFC_AddField IFC_DeleteEntry IFC_DeleteField
IFC_EnableEntry IFC_EnableObject IFC_GetEntriesCount IFC_GetEntryName
IFC_GetFieldMapping IFC_GetFieldName IFC_GetFieldType IFC_GetFieldsCount
IFC_IsEntryEnabled IFC_IsFieldEmpty IFC_IsFieldEnabled IFC_IsFieldOptional
IFC_IsObjectEnabled IFC_LoadMapSettings IFC_ReplaceDataWithMapping IFC_ResetMapToCOBieDefaults
IFC_ResetMapToDefaults IFC_SaveMapSettings IFC_SetFieldEmpty IFC_SetFieldEnabled
IFC_SetFieldMapping IFC_SetFieldType

Vectorworks Records

IFC_GetParamIndex IFC_GetParamName IFC_GetParamStyle IFC_GetParamValue
IFC_GetParamsCount IFC_GetRecordLocalizedName IFC_IsIFCRecord

Objects Support

IFC_GetSpaceParamForObject IFC_GetSpaceParamForObject2

Obsolete Members (not supported)

CloseForDocument GetIFCObjectData IFC_GetPsetProp UpdateVWDocumentIFCData

Remarks

There is predefined type for smart VCOM pointer VCOMPtr to IIFCSupport interface:

typedef VCOMPtr<IIFCSupport>  IIFCSupportPtr;

Version

Available from: Vectorworks 2013

See Also

IFC Enumerations

VCOM:VCOMPtr

[[VCOM:VectorWorks:IFCLib:IFCEnumerations|IFC Enumerations]] [[VCOM:VCOMPtr]]