VCOM:VectorWorks:IFCLib:IIFCSupport: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 74: Line 74:
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_AttachPset|IFC_AttachPset]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_AttachPset|IFC_AttachPset]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SetPsetProp|IFC_SetPsetProp]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SetPsetProp|IFC_SetPsetProp]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetPsetProp|IFC_GetPsetProp]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetPsetProp2|IFC_GetPsetProp2]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetPsetProp2|IFC_GetPsetProp2]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_ClearPset|IFC_ClearPset]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_ClearPset|IFC_ClearPset]]
Line 147: Line 146:
[[VCOM:VectorWorks:IFCLib:IIFCSupport::UpdateVWDocumentIFCData|UpdateVWDocumentIFCData]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::UpdateVWDocumentIFCData|UpdateVWDocumentIFCData]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::CloseForDocument|CloseForDocument]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::CloseForDocument|CloseForDocument]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetPsetProp|IFC_GetPsetProp]]
</listTable>
</listTable>



Latest revision as of 12:05, 27 August 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VCOM:VectorWorks:IFCLib

Provides access to IFC features of Vectorworks. Use all the functions via global pointer gIFC.

Members

I/O

ExportFile ImportFile

Dialogs

ShowExportOptions ShowIFCDataForSelection ShowManagePsetsDlg ShowObjectIFCDataEditDlg
ShowPickIFCTypeDlg ShowPickIFCTypeDlg2

Project Options

IFC_GetIFCScheme IFC_SetIFCScheme SetIFCScheme

Entities

GetAllIFCNamesInDocument GetIFCName GetIFCName2 GetIFCNameForSelection
GetIFCProperty IFC_ClearIFCInfo IFC_CopyIFCData IFC_CreateFormatEntity
IFC_CreateObjectGUID IFC_DeleteIFCInfo IFC_GetEntityColor IFC_GetEntityProp
IFC_GetEntityProp2 IFC_GetFullEntitiesList IFC_GetIFCEntity IFC_GetIFCEntity2
IFC_GetPropChoices IFC_GetPropertiesList IFC_SetEntityColor IFC_SetEntityProp
IFC_SetIFCEntity IFC_SetIFCEntity2 IFC_SetIFCProperty IFC_SetProperty

Property Sets (PSets)

IFC_AttachPset IFC_ClearAllPsets IFC_ClearPset IFC_DefPsetAddMember
IFC_DefPsetBegin IFC_DefPsetEnd IFC_GetNumPsets IFC_GetNumPsets2
IFC_GetPropertiesListOfPset IFC_GetPsetInfoAt IFC_GetPsetName IFC_GetPsetProp2
IFC_GetPsetsForIFCType IFC_IsPsetCustom IFC_IsPsetDefined IFC_SetPsetProp

COBie

IFC_GetCOBieProperty IFC_GetCOBieSource WS_FillCOBieFixedWorksheets

Data Mapping

IFC_AddEntry IFC_AddField IFC_DeleteEntry IFC_DeleteField
IFC_EnableEntry IFC_EnableObject IFC_GetEntriesCount IFC_GetEntryName
IFC_GetFieldMapping IFC_GetFieldName IFC_GetFieldType IFC_GetFieldsCount
IFC_IsEntryEnabled IFC_IsFieldEmpty IFC_IsFieldEnabled IFC_IsFieldOptional
IFC_IsObjectEnabled IFC_LoadMapSettings IFC_ReplaceDataWithMapping IFC_ResetMapToCOBieDefaults
IFC_ResetMapToDefaults IFC_SaveMapSettings IFC_SetFieldEmpty IFC_SetFieldEnabled
IFC_SetFieldMapping IFC_SetFieldType

Vectorworks Records

IFC_GetParamIndex IFC_GetParamName IFC_GetParamStyle IFC_GetParamValue
IFC_GetParamsCount IFC_GetRecordLocalizedName IFC_IsIFCRecord

Objects Support

IFC_GetSpaceParamForObject IFC_GetSpaceParamForObject2

Obsolete Members (not supported)

CloseForDocument GetIFCObjectData IFC_GetPsetProp UpdateVWDocumentIFCData

Remarks

There is predefined type for smart VCOM pointer VCOMPtr to IIFCSupport interface:

typedef VCOMPtr<IIFCSupport>  IIFCSupportPtr;

Version

Available from: Vectorworks 2013

See Also

IFC Enumerations

VCOM:VCOMPtr

[[VCOM:VectorWorks:IFCLib:IFCEnumerations|IFC Enumerations]] [[VCOM:VCOMPtr]]