VCOM:VectorWorks:IFCLib:IFCEnumerations

From Vectorworks Developer
Revision as of 13:16, 3 April 2018 by Sasha (talk | contribs)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

In IFC Support Library exist several enumerations which are used as input/output parameters from functions. Here is a list of them with some details.

EIFCSupportSchema

buildingSMART’s technical core is based around a common data schema (model) called IFC that makes it possible to hold and exchange relevant data between different software applications. That enumeration represents different versions of the IFC model (IFC schema).

Value Integer value Description
kIFCSupportScheme_2x2 0 IFC 2x2
kIFCSupportScheme_2x3 1 IFC 2x3
kIFCSupportScheme_2x4 2 IFC 4


ESourceValueType

This enumeration is used as out parameter in functions IFC_GetEntityProp2 and IFC_GetPsetProp2 called outMap.

Value Integer value Description
eNotSet -1 The source of the value is unknown. It could be treated as error code.
eFromInstance 0 The value comes from instance.
eFromMapping 1 The value comes from Data mapping.


ERecordIFCType

<lineList ident=0>

Value Integer value Description None 0 ... IFC 1 ... PSet 2 ... IFCTag 3 ...