VCOM:VectorWorks:IFCLib:IFCEnumerations: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 83: Line 83:
IFC Tag
IFC Tag
</line>
</line>
</lineList>
== EIfcType ==
This enumeration is of type Sint32 and represents the IFC type of fields.
<lineList ident=0>
<line>
'''Value'''
'''Description'''
</line>
<line>
kIfcType_UNKNOWN
</line>
<line>
kIfcType_IDENTIFIER
</line>
<line>
kIfcType_DOUBLE
</line>
<line>
kIfcType_BOOLEAN
</line>
<line>
kIfcType_INTEGER
</line>
<line>
kIfcType_NUMBER
</line>
<line>
kIfcType_LOGICAL
</line>
<line>
kIfcType_STRING
</line>
<line>
kIfcType_ENUMERATION
</line>
<line>
kIfcType_SELECT
</line>
<line>
kIfcType_ARRAY_IDENTIFIER
</line>
<line>
kIfcType_ARRAY_DOUBLE
</line>
<line>
kIfcType_ARRAY_BOOLEAN
</line>
<line>
kIfcType_ARRAY_INTEGER
</line>
<line>
kIfcType_ARRAY_NUMBER
</line>
<line>
kIfcType_ARRAY_LOGICAL
</line>
<line>
kIfcType_ARRAY_STRING
</line>
<line>
kIfcType_ARRAY_ENUMERATION
</line>
<line>
kIfcType_ARRAY_SELECT
</line>
<line>
kIfcType_LIST_IDENTIFIER
</line>
<line>
kIfcType_LIST_DOUBLE
</line>
<line>
kIfcType_LIST_BOOLEAN
</line>
<line>
kIfcType_LIST_INTEGER
</line>
<line>
kIfcType_LIST_NUMBER
</line>
<line>
kIfcType_LIST_LOGICAL
</line>
<line>
kIfcType_LIST_STRING
</line>
<line>
kIfcType_LIST_ENUMERATION
</line>
<line>
kIfcType_LIST_SELECT
</line>
<line>
kIfcType_SET_IDENTIFIER
</line>
<line>
kIfcType_SET_DOUBLE
</line>
<line>
kIfcType_SET_BOOLEAN
</line>
<line>
kIfcType_SET_INTEGER
</line>
<line>
kIfcType_SET_NUMBER
</line>
<line>
kIfcType_SET_LOGICAL
</line>
<line>
kIfcType_SET_STRING
</line>
<line>
kIfcType_SET_ENUMERATION
</line>
<line>
kIfcType_SET_SELECT
</line>
<line>
kIfcType_BINARY
</line>
<line>
kIfcType_LIST_BINARY
</line>
<line>
kIfcType_LIST_LIST_IDENTIFIER
</line>
<line>
kIfcType_LIST_LIST_DOUBLE
</line>
<line>
kIfcType_LIST_LIST_BOOLEAN
</line>
<line>
kIfcType_LIST_LIST_INTEGER
</line>
<line>
kIfcType_LIST_LIST_NUMBER
</line>
<line>
kIfcType_LIST_LIST_LOGICAL
</line>
<line>
kIfcType_LIST_LIST_STRING
</line>
<line>
kIfcType_LIST_LIST_ENUMERATION
</line>
<line>
kIfcType_LIST_LIST_SELECT
</line>
</lineList>

Revision as of 08:27, 21 May 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

In IFC Support Library exist several enumerations which are used as input/output parameters from functions. Here is a list of them with some details.

EIFCSupportSchema

buildingSMART’s technical core is based around a common data schema (model) called IFC that makes it possible to hold and exchange relevant data between different software applications. That enumeration represents different versions of the IFC model (IFC schema).

Value Integer value Description
kIFCSupportScheme_2x2 0 IFC 2x2
kIFCSupportScheme_2x3 1 IFC 2x3
kIFCSupportScheme_2x4 2 IFC 4


ESourceValueType

This enumeration is used as out parameter in functions IFC_GetEntityProp2 and IFC_GetPsetProp2 called outMap.

Value Integer value Description
eNotSet -1 The source of the value is unknown. It could be treated as error code.
eFromInstance 0 The value comes from instance.
eFromMapping 1 The value comes from Data mapping.


ERecordIFCType

This enumerations is used by VWFC classes to recognize the type of IFC records. For common purposes use None value. Use the other values only if you are sure for the type. The difference betwen types is in the record structure.

Value Integer value Description
None 0 Default values, it is used to identify the type of record by the IFC library.
IFC 1 IFC Entity
PSet 2 Pset
IFCTag 3 IFC Tag

EIfcType

This enumeration is of type Sint32 and represents the IFC type of fields.

Value Description
kIfcType_UNKNOWN
kIfcType_IDENTIFIER
kIfcType_DOUBLE
kIfcType_BOOLEAN
kIfcType_INTEGER
kIfcType_NUMBER
kIfcType_LOGICAL
kIfcType_STRING
kIfcType_ENUMERATION
kIfcType_SELECT
kIfcType_ARRAY_IDENTIFIER
kIfcType_ARRAY_DOUBLE
kIfcType_ARRAY_BOOLEAN
kIfcType_ARRAY_INTEGER
kIfcType_ARRAY_NUMBER
kIfcType_ARRAY_LOGICAL
kIfcType_ARRAY_STRING
kIfcType_ARRAY_ENUMERATION
kIfcType_ARRAY_SELECT
kIfcType_LIST_IDENTIFIER
kIfcType_LIST_DOUBLE
kIfcType_LIST_BOOLEAN
kIfcType_LIST_INTEGER
kIfcType_LIST_NUMBER
kIfcType_LIST_LOGICAL
kIfcType_LIST_STRING
kIfcType_LIST_ENUMERATION
kIfcType_LIST_SELECT
kIfcType_SET_IDENTIFIER
kIfcType_SET_DOUBLE
kIfcType_SET_BOOLEAN
kIfcType_SET_INTEGER
kIfcType_SET_NUMBER
kIfcType_SET_LOGICAL
kIfcType_SET_STRING
kIfcType_SET_ENUMERATION
kIfcType_SET_SELECT
kIfcType_BINARY
kIfcType_LIST_BINARY
kIfcType_LIST_LIST_IDENTIFIER
kIfcType_LIST_LIST_DOUBLE
kIfcType_LIST_LIST_BOOLEAN
kIfcType_LIST_LIST_INTEGER
kIfcType_LIST_LIST_NUMBER
kIfcType_LIST_LIST_LOGICAL
kIfcType_LIST_LIST_STRING
kIfcType_LIST_LIST_ENUMERATION
kIfcType_LIST_LIST_SELECT