VCOM:VectorWorks:IFCLib:IFCEnumerations: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 29: Line 29:
== ESourceValueType ==
== ESourceValueType ==
<lineList ident=0>
<lineList ident=0>
<line>
'''Value'''
'''Integer value'''
'''Description'''
</line>
<line>
<line>
eNotSet
eNotSet

Revision as of 07:41, 3 April 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

In IFC Support Library exist several enumerations which are used as input/output parameters from functions. Here is a list of them with some details.

EIFCSupportSchema

Value Integer value Description
kIFCSupportScheme_2x2 0 ...
kIFCSupportScheme_2x3 1 ...
kIFCSupportScheme_2x4 2 ...

ESourceValueType

Value Integer value Description
eNotSet -1 ...
eFromInstance 0 ...
eFromMapping 1 ...

ERecordIFCType

<lineList ident=0>

Value Integer value Description None 0 ... IFC 1 ... PSet 2 ... IFCTag 3 ...