VCOM:VectorWorks:IFCLib:IFCEnumerations: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
mNo edit summary
No edit summary
Line 2: Line 2:
__TOC__
__TOC__
In [[VCOM:VectorWorks:IFCLib:IIFCSupport|IFC Support Library]] exist several enumerations which are used as input/output parameters from functions. Here is a list of them with some details.
In [[VCOM:VectorWorks:IFCLib:IIFCSupport|IFC Support Library]] exist several enumerations which are used as input/output parameters from functions. Here is a list of them with some details.
== EIFCSupportSchema ==
<lineList ident=0>
<line>
'''Value'''
'''Integer value'''
'''Description'''
</line>
<line>
kIFCSupportScheme_2x2
0
...
</line>
<line>
kIFCSupportScheme_2x3
1
...
</line>
<line>
kIFCSupportScheme_2x4
2
...
</line>
</lineList>
== ERecordIFCType ==
<lineList ident=0>
<line>
'''Value'''
'''Integer value'''
'''Description'''
</line>
<line>
None
0
...
</line>
<line>IFC
1
...
</line>
<line>
PSet
2
...
</line>
<line>
IFCTag
3
...
</line>

Revision as of 08:07, 26 March 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

In IFC Support Library exist several enumerations which are used as input/output parameters from functions. Here is a list of them with some details.

EIFCSupportSchema

Value Integer value Description
kIFCSupportScheme_2x2 0 ...
kIFCSupportScheme_2x3 1 ...
kIFCSupportScheme_2x4 2 ...


ERecordIFCType

<lineList ident=0>

Value Integer value Description None 0 ... IFC 1 ... PSet 2 ... IFCTag 3 ...