VCOM:VectorWorks:IFCLib:IFCEnumerations: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(9 intermediate revisions by the same user not shown)
Line 1: Line 1:
{{LocationMain|category=LocationVCOM|specific=}}
{{LocationMain|category=LocationVCOM|specific=}}
__TOC__
__TOC__
<vwDoc>
In [[VCOM:VectorWorks:IFCLib:IIFCSupport|IFC Support Library]] exist several enumerations which are used as input/output parameters from functions. Here is a list of them with some details.
In [[VCOM:VectorWorks:IFCLib:IIFCSupport:IFC Support Library]] exist several enumerations which are used as input/output parameters from functions. Here is a list of them with some details.


== EIFCSupportSchema ==
[https://www.buildingsmart.org/about/what-is-openbim/ifc-introduction/ buildingSMART’s] technical core is based around a common data schema (model) called IFC that makes it possible to hold and exchange relevant data between different software applications. That enumeration represents different versions of the IFC model (IFC schema).
<lineList ident=0>
<line>
'''Value'''
'''Integer value'''
'''Description'''
</line>
<line>
kIFCSupportScheme_2x2
0
IFC 2x2
</line>
<line>
kIFCSupportScheme_2x3
1
IFC 2x3
</line>
<line>
kIFCSupportScheme_2x4
2
IFC 4
</line>
</lineList>


</vwDoc>
 
 
== ESourceValueType ==
This enumeration is used as out parameter in functions [[VCOM:VectorWorks:Extension:IIFCSupport::IFC_GetEntityProp2|IFC_GetEntityProp2]] and [[VCOM:VectorWorks:Extension:IIFCSupport::IFC_GetPsetProp2|IFC_GetPsetProp2]] called '''outMap'''.
<lineList ident=0>
<line>
'''Value'''
'''Integer value'''
'''Description'''
</line>
<line>
eNotSet
-1
The source of the value is unknown. It could be treated as error code.
</line>
<line>
eFromInstance
0
The value comes from instance.
</line>
<line>
eFromMapping
1
The value comes from Data mapping.
</line>
</lineList>
 
 
== ERecordIFCType ==
This enumerations is used by VWFC classes to recognize the type of IFC records. For common purposes use '''None''' value. Use the other values only if you are sure for the type. The difference betwen types is in the record structure.
<lineList ident=0>
<line>
'''Value'''
'''Integer value'''
'''Description'''
</line>
<line>
None
0
Default values, it is used to identify the type of record by the IFC library.
</line>
<line>IFC
1
IFC Entity
</line>
<line>
PSet
2
Pset
</line>
<line>
IFCTag
3
IFC Tag
</line>
</lineList>
 
== EIfcType ==
This enumeration is of type Sint32 and represents the IFC type of fields.
<lineList ident=0>
<line>
'''Value'''
'''Integer value'''
'''Description'''
</line>
<line>
kIfcType_UNKNOWN
0
 
</line>
<line>
kIfcType_IDENTIFIER
1
</line>
<line>
kIfcType_DOUBLE
2
</line>
<line>
kIfcType_BOOLEAN
3
</line>
<line>
kIfcType_INTEGER
4
</line>
<line>
kIfcType_NUMBER
5
</line>
<line>
kIfcType_LOGICAL
6
</line>
<line>
kIfcType_STRING
7
</line>
<line>
kIfcType_ENUMERATION
8
</line>
<line>
kIfcType_SELECT
9
</line>
<line>
kIfcType_ARRAY_IDENTIFIER
10
</line>
<line>
kIfcType_ARRAY_DOUBLE
11
</line>
<line>
kIfcType_ARRAY_BOOLEAN
12
</line>
<line>
kIfcType_ARRAY_INTEGER
13
</line>
<line>
kIfcType_ARRAY_NUMBER
14
</line>
<line>
kIfcType_ARRAY_LOGICAL
15
</line>
<line>
kIfcType_ARRAY_STRING
16
</line>
<line>
kIfcType_ARRAY_ENUMERATION
17
</line>
<line>
kIfcType_ARRAY_SELECT
18
</line>
<line>
kIfcType_LIST_IDENTIFIER
19
</line>
<line>
kIfcType_LIST_DOUBLE
20
</line>
<line>
kIfcType_LIST_BOOLEAN
21
</line>
<line>
kIfcType_LIST_INTEGER
22
</line>
<line>
kIfcType_LIST_NUMBER
23
</line>
<line>
kIfcType_LIST_LOGICAL
24
</line>
<line>
kIfcType_LIST_STRING
25
</line>
<line>
kIfcType_LIST_ENUMERATION
26
</line>
<line>
kIfcType_LIST_SELECT
27
</line>
<line>
kIfcType_SET_IDENTIFIER
28
</line>
<line>
kIfcType_SET_DOUBLE
29
</line>
<line>
kIfcType_SET_BOOLEAN
30
</line>
<line>
kIfcType_SET_INTEGER
31
</line>
<line>
kIfcType_SET_NUMBER
32
</line>
<line>
kIfcType_SET_LOGICAL
33
</line>
<line>
kIfcType_SET_STRING
34
</line>
<line>
kIfcType_SET_ENUMERATION
35
</line>
<line>
kIfcType_SET_SELECT
36
</line>
<line>
kIfcType_BINARY
37
</line>
<line>
kIfcType_LIST_BINARY
38
</line>
<line>
kIfcType_LIST_LIST_IDENTIFIER
39
</line>
<line>
kIfcType_LIST_LIST_DOUBLE
40
</line>
<line>
kIfcType_LIST_LIST_BOOLEAN
41
</line>
<line>
kIfcType_LIST_LIST_INTEGER
42
</line>
<line>
kIfcType_LIST_LIST_NUMBER
43
</line>
<line>
kIfcType_LIST_LIST_LOGICAL
44
</line>
<line>
kIfcType_LIST_LIST_STRING
45
</line>
<line>
kIfcType_LIST_LIST_ENUMERATION
46
</line>
<line>
kIfcType_LIST_LIST_SELECT
47
</line>
</lineList>

Latest revision as of 07:19, 10 September 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

In IFC Support Library exist several enumerations which are used as input/output parameters from functions. Here is a list of them with some details.

EIFCSupportSchema

buildingSMART’s technical core is based around a common data schema (model) called IFC that makes it possible to hold and exchange relevant data between different software applications. That enumeration represents different versions of the IFC model (IFC schema).

Value Integer value Description
kIFCSupportScheme_2x2 0 IFC 2x2
kIFCSupportScheme_2x3 1 IFC 2x3
kIFCSupportScheme_2x4 2 IFC 4


ESourceValueType

This enumeration is used as out parameter in functions IFC_GetEntityProp2 and IFC_GetPsetProp2 called outMap.

Value Integer value Description
eNotSet -1 The source of the value is unknown. It could be treated as error code.
eFromInstance 0 The value comes from instance.
eFromMapping 1 The value comes from Data mapping.


ERecordIFCType

This enumerations is used by VWFC classes to recognize the type of IFC records. For common purposes use None value. Use the other values only if you are sure for the type. The difference betwen types is in the record structure.

Value Integer value Description
None 0 Default values, it is used to identify the type of record by the IFC library.
IFC 1 IFC Entity
PSet 2 Pset
IFCTag 3 IFC Tag

EIfcType

This enumeration is of type Sint32 and represents the IFC type of fields.

Value Integer value Description
kIfcType_UNKNOWN 0
kIfcType_IDENTIFIER 1
kIfcType_DOUBLE 2
kIfcType_BOOLEAN 3
kIfcType_INTEGER 4
kIfcType_NUMBER 5
kIfcType_LOGICAL 6
kIfcType_STRING 7
kIfcType_ENUMERATION 8
kIfcType_SELECT 9
kIfcType_ARRAY_IDENTIFIER 10
kIfcType_ARRAY_DOUBLE 11
kIfcType_ARRAY_BOOLEAN 12
kIfcType_ARRAY_INTEGER 13
kIfcType_ARRAY_NUMBER 14
kIfcType_ARRAY_LOGICAL 15
kIfcType_ARRAY_STRING 16
kIfcType_ARRAY_ENUMERATION 17
kIfcType_ARRAY_SELECT 18
kIfcType_LIST_IDENTIFIER 19
kIfcType_LIST_DOUBLE 20
kIfcType_LIST_BOOLEAN 21
kIfcType_LIST_INTEGER 22
kIfcType_LIST_NUMBER 23
kIfcType_LIST_LOGICAL 24
kIfcType_LIST_STRING 25
kIfcType_LIST_ENUMERATION 26
kIfcType_LIST_SELECT 27
kIfcType_SET_IDENTIFIER 28
kIfcType_SET_DOUBLE 29
kIfcType_SET_BOOLEAN 30
kIfcType_SET_INTEGER 31
kIfcType_SET_NUMBER 32
kIfcType_SET_LOGICAL 33
kIfcType_SET_STRING 34
kIfcType_SET_ENUMERATION 35
kIfcType_SET_SELECT 36
kIfcType_BINARY 37
kIfcType_LIST_BINARY 38
kIfcType_LIST_LIST_IDENTIFIER 39
kIfcType_LIST_LIST_DOUBLE 40
kIfcType_LIST_LIST_BOOLEAN 41
kIfcType_LIST_LIST_INTEGER 42
kIfcType_LIST_LIST_NUMBER 43
kIfcType_LIST_LIST_LOGICAL 44
kIfcType_LIST_LIST_STRING 45
kIfcType_LIST_LIST_ENUMERATION 46
kIfcType_LIST_LIST_SELECT 47