VCOM:VectorWorks:Filing:IStdFile::WriteUnicodeMarker: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:Filing:IStdFile]]
Member of [[VCOM:VectorWorks:Filing:IStdFile]]


...put some description here...
Write the UTF-16 Unicode marker: 0xFF 0xFE
This marker must be at the beginning of a Text file to represent that this text file is in UTF-16 Unicode encoding.
</desc>
</desc>



Revision as of 17:47, 19 September 2013

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IStdFile

Write the UTF-16 Unicode marker: 0xFF 0xFE This marker must be at the beginning of a Text file to represent that this text file is in UTF-16 Unicode encoding.

virtual VCOMErrorVCOM_CALLTYPE WriteUnicodeMarker( ) = 0;

Parameters

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Version

Availability: from Vectorworks 2014